Skip to content

InstanceResource Error when install, Could not find disk that exists #211

Description

@dd-guo

sealer run -f ClusterFile failed, could not find disk that exists

Bug Report

Type: bug report

What happened

Trident version 1.14.3, Build: d1412075 go1.17.2, Build time: 2023-03-31-11-38-17, EnableLicense: false, Log file: /var/lib/sealer/data/my-cluster/rootfs/trident_log_2023-04-07T11-53-58+08-00
failed to validate cluster:
[Validator:InstanceResource on host:172.25.132.244] fails: [FATAL] failed to find device /dev/nvme1n1, which is assigned as StorageDevice;device /dev/nvme1n1, which is assigned as StorageDevice, need 150 GB, but only has 0.00 GB. You can 'lsblk' on host 172.25.132.244 to choose an right disk, and this error can't be ignored, please check your cluster.
[Validator:InstanceResource on host:172.25.132.246] fails: [FATAL] failed to find device /dev/nvme1n1, which is assigned as StorageDevice;device /dev/nvme1n1, which is assigned as StorageDevice, need 150 GB, but only has 0.00 GB. You can 'lsblk' on host 172.25.132.246 to choose an right disk, and this error can't be ignored, please check your cluster.
[Validator:InstanceResource on host:172.25.132.245] fails: [FATAL] failed to find device /dev/nvme1n1, which is assigned as StorageDevice;device /dev/nvme1n1, which is assigned as StorageDevice, need 150 GB, but only has 0.00 GB. You can 'lsblk' on host 172.25.132.245 to choose an right disk, and this error can't be ignored, please check your cluster..
You can see entire survey report in /var/lib/sealer/data/my-cluster/rootfs/site-survey-report.yaml

What you expected to happen

should recognize /dev/nvme1n1 disk

How to reproduce it (as minimally and precisely as possible)

sealer run -f ClusterFile

Anything else we need to know?

my clusterFile

kind: Cluster
metadata:
  name: my-cluster # must be my-cluster
spec:
  image: ack-agility-registry.cn-shanghai.cr.aliyuncs.com/ecp_builder/ackdistro:v1-22-15-ack-10
  containerRuntime:
    type: docker # which container runtime, support containerd/docker, default is docker
  registry:
    #externalRegistry: # external registry configuration
    #  domain: ack-agility-registry.cn-shanghai.cr.aliyuncs.com # if use lite mode image, externalRegistry must be set as this
    localRegistry: # local registry configuration
      domain: sea.hub # domain for local registry, default is sea.hub
      port: 5000 # port for local registry, default is 5000
  env:
    #- EtcdDevice="" # EtcdDevice is device for etcd, default is "", which will use system disk
    - StorageDevice=/dev/nvme1n1 # StorageDevice is device for kubelet and container daemon, default is "", which will use system disk
    - YodaDevice=/dev/nvme1n1 # YodaDevice is device for open-local, if not specified, open local can't provision pv
    - DockerRunDiskSize=120 # unit is GiB, capacity for /var/lib/docker, default is 100
    - KubeletRunDiskSize=30 # unit is GiB, capacity for /var/lib/kubelet, default is 100
    # - Addons=paralb,kube-prometheus-crds,ack-node-problem-detector
    - Network=calico # support hybridnet/calico, default is hybridnet
    - DNSDomain=cluster.local # default is cluster.local
    - ServiceNodePortRange=30000-32767 # default is 30000-32767
    - EnableLocalDNSCache=false # enable local dns cache component, default is false
    - RemoveMasterTaint=false # remove master taint or not, default is false
    - IgnoreErrors=InstanceResource # ignore errors for preflight
    # - TrustedRegistry=your.registry.url # Registry Domain to be trusted by container runtime

mydisks
NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
nvme0n1 259:0 0 40G 0 disk
├─nvme0n1p1 259:2 0 191M 0 part /boot/efi
└─nvme0n1p2 259:3 0 39.8G 0 part /
nvme2n1 259:4 0 20G 0 disk
nvme1n1 259:1 0 200G 0 disk
└─nvme1n1p1 259:5 0 200G 0 part

Environment

  • ACK Distro version: v1-22-15-ack-10
  • OS (e.g. cat /etc/os-release): CentOS 7
  • Kernel (e.g. uname -a): 4.18.0-348.20.1.el7.aarch64
  • Others:

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions